BLOG:CMS :: Support Forum

Support Forum for BLOG:CMS

You are not logged in.

#1 02.01.2006 08:20

nkannan
BLOG:CMS Senior
Registered: 06.09.2005
Posts: 62

Wiki open error after 1st installation

Hi

I managed to install Wiki by not uploading any .htaccess file or .cache folder (even if I install I am not able to view them in File manager or FTP client).

On my first view and subsequent views I get the following message:


Writing ./data/.cache/7ecacbc05cf02eb77a1a73ccacf11b4f failed


Of course, there is no ".cache" folder, instead just "cache" folder (what is this period notation mean? and why does it give problem in my server?).

The file/folder permissions are correct and proofed.

How to solve this error message? Except this message the page seems OK.

Any suggestion?

Kannan


Eager to learn

Offline

 

#2 02.01.2006 11:41

Radek Hulán
Site Admin
From: Prague, Czech Republic
Registered: 17.03.2004
Posts: 2509
Website

Re: Wiki open error after 1st installation

there *is* /wiki/data/.cache folder, and according to Installation manual, you have to set it writeable (chmod 0777). Most  FTP clients do not show files beginning with "dot", so you have to chmod it manually


--= BLOG:CMS developer =--

Offline

 

#3 03.01.2006 02:25

nkannan
BLOG:CMS Senior
Registered: 06.09.2005
Posts: 62

Re: Wiki open error after 1st installation

Dear Radek:

Once a folder or a file begins with a 'period' it becomes a Phantom folder or file and I can't see it to edit or change permissions. This is the real problem! I can't manually change anything in this case. Is there still a way out?

Thank you for your time.

Kannan


Eager to learn

Offline

 

#4 03.01.2006 02:36

Radek Hulán
Site Admin
From: Prague, Czech Republic
Registered: 17.03.2004
Posts: 2509
Website

Re: Wiki open error after 1st installation

Not really, .htaccess also begins with a "dot" and my FTP client shows it. But I will consider changing ".cache" to "cache" :-)


--= BLOG:CMS developer =--

Offline

 

#5 04.01.2006 09:14

nkannan
BLOG:CMS Senior
Registered: 06.09.2005
Posts: 62

Re: Wiki open error after 1st installation

It's funny! In my Canadian server (Bravanet.com) whenever I insert 'period' in the file/folder name it becomes invisible! Hence, a third party FTP client (I use AlFTP and/or WS_FTP) could not see those files/folders in my server. I asked the Bravanet technical team to sort out this.

In the mean time I followed your suggestion. I changed file permission to wiki/media/cache and even after that I get error message

<Writing ./data/.cache/7ecacbc05cf02eb77a1a73ccacf11b4f failed>

I supect that there is no .htaccess file inside (if there is I can't see it anyway). Is it OK to create a htaccess without 'period'? Will it work?

I noticed that I can not edit my Wiki (a related problem?). Before I follow the suggestions given in this forum for Wiki-editing I want to settle with .cache and .htaccess.

Any suggestion? Thanks.


Eager to learn

Offline

 

#6 04.01.2006 12:43

Radek Hulán
Site Admin
From: Prague, Czech Republic
Registered: 17.03.2004
Posts: 2509
Website

Re: Wiki open error after 1st installation

try setting "chmod 0777" on .cache directory and *all files inside it*, including 7ecacbc05cf02eb77a1a73ccacf11b4f. Also try CuteFTP Pro, I use this FTP client, and it shows "dot" files.


--= BLOG:CMS developer =--

Offline

 

#7 05.01.2006 03:02

nkannan
BLOG:CMS Senior
Registered: 06.09.2005
Posts: 62

Re: Wiki open error after 1st installation

Its Great! Finally I managed to "see" the hidden files using WS_FTP. I need to set properties in the 'start-up' to remote file mask! Once I change this property (see help for details), now I can see both .cache and .htaccess. I did change the permission to wiki/data/.cache and I do not see the error message anymore. Thank you for the suggesstion.

However, I still could not edit my pages! This is next :-) I need to follow the thread in this forum on this topic now!


Eager to learn

Offline

 

#8 06.01.2006 01:04

JaceMan
BLOG:CMS Junior
Registered: 31.12.2005
Posts: 23
Website

Re: Wiki open error after 1st installation

nkannan wrote:

It's funny! In my Canadian server (Bravanet.com) whenever I insert 'period' in the file/folder name it becomes invisible! Hence, a third party FTP client (I use AlFTP and/or WS_FTP) could not see those files/folders in my server. I asked the Bravanet technical team to sort out this.

The reason is simple... a filename beginning with a DOT (.) means to hide the file.  .fileName files are hidden by default -- with most 3rd party clients there is an option to Show Hidden Files and then you will be able to see, edit, etc. those files.


oink, oink

Offline

 

#9 06.01.2006 03:45

nkannan
BLOG:CMS Senior
Registered: 06.09.2005
Posts: 62

Re: Wiki open error after 1st installation

Thanks. I understood that by now. As you rightly say, 'someday I figure out every thing' :-)

Unfortunately a weird thing happed now. While trying to figure out the 'edit' mode in Wiki, I did something that I am back to square one now. When I click Wiki from my BlogCMS I do not see anything! Not even an error message!!

I reinstalled the Wiki module once again and gave permission properly (.htaccess deleted) but nothing appears! A blank screen.

Anybody has this experience?

Kannan

Last edited by nkannan (06.01.2006 04:34)


Eager to learn

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson

TOPlist